ティラノビルダー交流掲示板 207934


ノベルゲーム制作ツール、「ティラノビルダー」に関する掲示板です
ティラノスクリプトに関する質問等はティラノ交流掲示板でお願いします。

質問を書き込む前に

こんな機能ないかな?と思った時
ティラノスクリプトのタグリファレンス

ティラノWikiも確認
http://tyrano.wiki.fc2.com/

バグ報告や質問、要望などご自由にお使い下さい。


【旧バージョン専用】不具合報告スレッド

1:シケモクMK :

2014/03/18 (Tue) 13:27:49

このスレッドはVer 1.0 より前のティラノビルダーについて扱います。
なお、旧バージョンはサポートを停止してますので
可能でしたら新ティラノビルダーへの移行をお願い致します。

不具合を発見されましたら、こちらにご報告いただけると幸いです。
その際、ご利用のOS、現象が発生する手順などもお知らせいただけると助かります。

なお、こちらのスレッドはβ版終了後に別スレへ移動する予定です。
2:十海 :

2014/04/12 (Sat) 05:58:28

お世話になります。
ティラノビルダーでコンポーネント「ティラノスクリプト」を打ち込んだ時
変数削除([eval exp="delete.f.flag1"] )と変数全削除([clearvar])を入れると
プレビュー画面が真っ黒になって固まる現象が発生いたしました。
個々の変数演算は動きますが削除ができない状態です。
使用しているOSはMac10.9.2、ティラノビルダーはver0.1.2(4/6更新分)です。
同じ症状が出てる方がいるのかどうか、私個人の環境だけの問題なのかどうか。
確認のためにもこちらに書き込ませていただきました。
3:あき :

2014/04/12 (Sat) 21:23:59


ティラノビルダーでゲームを作っているのですが、メッセージウィンドウを表示させなくして文字だけを表示させる場合はどうしたらいいですか?
4:ARN :

2014/04/21 (Mon) 01:11:22

お世話になっております。

ver 0.1.2にて、コンポーネント「ティラノスクリプト」を打ち込んだとき、
[autosave]タグを入れていると進行不能になる現象が発生しました。

上記タグを入れない場合、正常に動作しています。

すみませんが、ご確認よろしくお願いいたします。
5:ARN :

2014/04/21 (Mon) 01:17:30

>>3
あきさん

透明なpng画像を用意し、それをメッセージウインドウに指定すればいけるかと思います。
(メッセージウインドウを表示させないのではなく、透明なメッセージウインドウの上に文字を出す感じ)

tyranobuilder_win_v012\myproject\(プロジェクト名)\data\scenario内に、first.ksがあると思います。
このスクリプトファイルを開き、

[position layer=message0 page=fore frame="frame.png" margint="65" marginl="50" marginr="70" marginb="60"]

↑ここの"frame.png"のところを用意した透明な画像のファイル名にしてやれば、表示されるメッセージウインドウが透明な画像になり、
その上に文字を表示させることもできるかと思います。

自分はこの方法でメッセージウインドウを自前のものに変更したので、おそらくいけるかと思いますが、
意図したことと違っていたらすみません。
6:sige :

2014/04/24 (Thu) 18:18:06

ティラノビルダー利用させて頂きました。
プレビューにて、タイトル画面から「つづきから」を選択しセーブデータを表示させた後、
☓ボタンでキャンセルしてタイトルに戻った際、「はじめから」「つづきから」のボタンが表示されなくなり
進行不可能になるようなのでご確認お願いします。

使用環境はWindows7 64bit版となります。
7:シケモクMK :

2014/04/25 (Fri) 15:09:11

>>6

こんにちは。
ご報告、誠に有難うございます。

Windows版が古いバージョンになっていたようです。
再度ダウンロードしてお試しいただけますでしょうか。

お手数おかけして申し訳ありません。
8: :

2014/04/30 (Wed) 10:43:41

ティラノビルダーを少し触らせてもらったところ、4対3画面のサウンドノベルモードにしたときに、画面サイズとメッセージウィンドウのサイズが合っていないことがありました。
サウンドノベルモード小画面640×480の画面やカスタム画面で800×600などにしたときにメッセージウィンドウが画面の半分ほどの大きさになっていました。
960の大画面では正常でした。
ご確認お願いします。
9: :

2014/04/30 (Wed) 10:49:32

上に書き込みに追記です。
環境はWIN8の64ビット環境です。
画面解像度は1920×1080です。
10:ユウ :

2014/05/01 (Thu) 20:48:32

私のミスかと思ったのですが…
一応、こちらに報告しておきます。

[button role="message" graphic="menu_button_close.png" 位置指定]

とシンプルに書いたのですがウインドウが消えません。
ほかの role はきちんと機能しているのですが…
massageだけ機能しません。なにかしらのこちらのミスかと思い、
質問スレのほうに行こうかと思ったのですが、こちらで報告させてもらいました。

環境はWin8.1 64bit です。
よろしくお願いいたします。
11:AM :

2014/05/02 (Fri) 20:04:43

素晴らしいツールを公開して頂き心から感謝しております。ありがとうございます。

不具合についてのご報告です。
既に出ているものかもしれませんがご参考になれば幸いです。

■テキストや改行、効果音、ティラノスクリプトで直に打ち込んだ項目が
3つほど複製される現象。

■下の方に作った項目が主に上部に勝手に移動している場合が多々見られました。

現在の所、この二点のみになります。
ティラノビルダーの更なる発展を期待いたします。
何卒よろしくお願いいたします。
12:シケモクMK :

2014/05/03 (Sat) 22:22:27

>>10
ユウ さん

こんにちは。ご報告大変有難うございます。
>>[button role="message" graphic="menu_button_close.png" 位置指定]

こちらについて、リファレンスの記述が間違っておりました。
正しくはrole="window" となります。

リファレンスも修正しておきます。
大変失礼いたしました。よろしくお願いいたします。
13:シケモクMK :

2014/05/03 (Sat) 22:25:35

>>11
AM さん

こんにちは。ティラノビルダーを使っていただき、有難うございます。
バグ報告について、誠にありがとうございます。

修正し、対応いたします。
症状について質問させていただくかもしれませんが、何卒よろしくお願いいたします。
14: :

2014/05/04 (Sun) 23:50:03

こんにちは

ビルダーで設定した背景の切り替え効果がうまく反映されません。
具体的には↓のurlを見てもらうとわかりやすいかと思うのですが、
「スライド」や「ブラインド」などが「クロスフェード」と同じ効果になってしまい、
「シェイク」が「スライド」の効果になっているような気がします。
http://tyramemo.o-oku.jp/effect/

自分に違いがわからないだけでそれぞれ違う変化をしているのかな?とも思っていたのですが、
ティラノスクリプトのほうで公開されたテクニックサンプル集をプレイしていてようやく反映されてないんだと思った次第です;

また、シナリオエリアのコピー&ペーストについて、Ctrlを押しながらクリックしても複数選択できません。

環境はwin8.1、64bitです。
確認よろしくお願いします。
15: :

2014/05/05 (Mon) 01:06:52

度々すみません

>>7を見てビルダーを再ダウンロードしたところ、背景の切り替え効果については改善されました。
問題なく反映されます。

ただシナリオエリアのコピー&ペーストに関しては複数選択できません。
対応よろしくお願いします。
16:ユウ :

2014/05/05 (Mon) 06:14:03

>>12
シケモクMK様
あー。なるほど、そうでしたか。
リファレンスの方の修正も確認いたしました。
お疲れ様でした&ありがとうございました。
17:シケモクMK :

2014/05/05 (Mon) 23:35:30

>>15

シナリオエリアのコピペについて
Windows版では仰るとおり複数選択できない現象を確認いたしました
次回アップデートで修正いたします。
ご報告、誠に有難うございます。
18:reki :

2014/05/13 (Tue) 05:37:12

ティラノビルダー dlしたのですが、ダブルクリックしても右クリックで開くを押しても、
まったく開いてくれません。
試しにもう一回 dlしても変化は見られませんでした。

解決方法があるのであれば、どうか教えてください。

使っているOSはwin7です。

19:ニュルンベルク :

2014/05/21 (Wed) 22:38:27

不具合報告と思ったので此方へ。

テキストにて、
目を覚ました[emb exp="sf.name"]。
とやりますと、
以下の様な状態になります。

―――以下状態―――
目を覚ました(この後にあった筈の入力が消える)
。(何故か別で立てられる)
―――以上状態―――
コレに関して何か対処ありましたらお願いします。
それと、不具合でしたら検証お願いします。
なお、名前入力に関しては予め確認しているようにしてます。
20:ニュルンベルク :

2014/05/22 (Thu) 12:02:52

>>19追記
すいません、OSはWindows7 32ビットです。
21:十海 :

2014/05/22 (Thu) 14:37:53

>>19
ニュルンベルクさんへ
そこはテキストコンポーネントではなく「ティラノスクリプト」コンポーネントに打ち込むと出力できますよ。
ただ今度は改行が反映されなくなるので、文末に[l][r](クリックを待って改行)か[p](改ページ)、[r](クリックを待たずに改行)等のタグを入れる必要が出てきます。
22:ニュルンベルク :

2014/05/23 (Fri) 11:00:06

>>21
ああ、成程・・・。
解決しました。ありがとうございます。
23:きいち :

2014/05/25 (Sun) 15:33:33

こんにちは

ティラノビルダーでの不具合です。
「画像ボタン」で分岐点を作った際、次の画面までいってもその分岐画像ボタンが
表示されたままになり、しかも動作がなぜか翌テキストの「一行目」で止まってしまいます。

つまり、

「行く」
「行かない」

というボタンをつくり、「行く」を押した後のテキスト(例「ああ、一緒に行こう!(クリックで)
独りぼっちは寂しいしな!」)を用意していても、なぜか「ああ、一緒に行こう!」しか読み込まれず、
の上にはまだ「行く」「行かない」のボタンが表示されている、という状態です。
(「行かない」ボタンを押しても同様です。プレビュー画面ではそのまま固まってしまいます)

普通の分岐ボタンならちゃんとできるのですが、画像ボタンにすると不具合が出ます。
なにとぞ、宜しくお願いします。
24:十海 :

2014/05/25 (Sun) 16:31:08

>>23 きいちさんへ
移動先のシーンでラベルの直後に「改ページ」を入れれば画像ボタンは消えるはずです。
メッセージが止まってしまう原因はわからないのですが、取り急ぎお返事まで。
25:きいち :

2014/05/25 (Sun) 18:41:28

>>24 十海さんへ

ありがとうございます。
ラベル直後に「改ページ」を入れたところ、
無事、移動先シーンで画像ボタンを消すことができました。
(また、以後のメッセージもちゃんと動くようになりました)

どういう理由でメッセージが止まってしまっていたのかは分からずじまいですが、
ありがとうございます。

本当に助かりました……!
26:taro :

2014/06/10 (Tue) 00:21:09

クエイクの縦揺れですが、数値入れても反映しないです。

OS:win7 最新をダウンロードしてるのでティラノビルダーのバージョンは0.1.6のはずです。
 (ヘルプ>バージョンを確認は0.1.4と出てます)
27:taro :

2014/06/12 (Thu) 23:29:34

クエイクですが
scene1.ks を開いて hmax="0" を消すと縦揺れするようになりました!
(hmaxが記載されてると縦揺れしないようです)

[quake time="500" count="2" wait="false" vmax="50" hmax="0" ]
↑これだと横揺れします

[quake time="500" count="2" wait="false" vmax="50" ]
↑これで縦揺れしました

OS:Win7 です
28:AM :

2014/06/21 (Sat) 05:09:17

ティラノビルダー上で効果音再生について、
音を鳴らす事が出来ません。

設定した効果音がパラメータ欄の音楽再生の所で
確認の為に再生できる様になっていると思うのですが、
設定した時は再生可能ですが、一度保存を行って
閉じ、再度読み込みをすると本来再生できるはずの音が
グレー表示になってしまっており再生する事が出来なくなる現象が発生しました。

何度か試したのですが、同じ現象が発生します。
尚、別のシナリオでは発生せず、そのシナリオのみ発生しました。
29:AM :

2014/06/22 (Sun) 06:03:02

↑28

ファイル名が長かった事が原因の様でした。
自己解決致しました、申し訳ございません。
30:むつ :

2014/06/22 (Sun) 11:21:16

Macの0.1.6の最新版をダウンロードしました。
ダウンロードファイルも「tyranobuilder_mac_v016.zip」なのですが
アプリケーションの「バージョンを確認」ではver0.1.4になっています。
どちらが、正しいのでしょうか。
ご確認ください。
31:十海 :

2014/06/22 (Sun) 21:55:37

>>30
むつさんと同様、Mac版0.1.6で「バージョンを確認」すると0.1.4と表示されます。
……が、0.1.4であった「イメージを表示」の時に生じたバグがきれいに修正されているので問題ないと思うんですがいかがでしょう?
32:むつ :

2014/06/23 (Mon) 08:48:33

>>31
十海さま。バグ修正されていて
「バージョン表記が未修正」ということなんでしょうね。
これから勉強するので0.1.6の現バージョンしか触ってなかったので、
わかりませんでした。情報ありがとうございます。
33:テストロン :

2014/06/25 (Wed) 21:20:43

お世話になります。

質問スレでだいきちさんからも報告があったのと同じ、
「セーブ時の確認メッセージウィンドウの中味が見切れていてボタンが押しづらい」という不具合が起きていて難儀しています。

以下に該当レスにあったキャプチャ画像を引用させていただきます。
http://bbs8.fc2.com//bbs/img/_811700/811649/full/811649_1396019357.png

確認ボタンのクリックできる部分が体感2ピクセルくらいしかなく、とても作業が進めづらい状況です。
せめてEnterキーでパスできるといいのですが・・・

OSはWindowsXPです。

ご確認をよろしくお願い致します。
34:鉄狼:

2014/07/01 (Tue) 01:05:50

http://bbs8.fc2.com//bbs/img/_811700/811649/full/811649_1404144350.png ティラノビルダーを使い始めています、鉄狼です。
素敵なツールをありがとうございます。

さて、Macで扱っていたところ、いくつか不具合が出てきましたのでその報告をさせていただきます
OSはMac OSX 10.9.3です。

1:ツールバーの「ファイル」→「保存」でティラノビルダーが落ちる。

2:スマートフォンモードのビジュアルノベル形式で、キャラクター登場をさせると、先に進まなくなる。

以上の二点がありました。

不具合ではなかったら申し訳ありません


35:燈火 :

2014/07/15 (Tue) 12:49:37

最近ティラノビルダーを使い始めた者ですが、三個目の新規シナリオを作成して、キャラクターを表示させようとしたのですが、登場する前に画面が止まってしまいます。
最初に登録しておいたキャラクターは三個目のシナリオからでも登場しますが、新規でつくったキャラクターのみが表示されずに困っています。
一個目と二個目には、先ほど表示されなかった新規のキャラクターも登場することが出来ていて何か不具合があるのかと思っています。
宜しくお願い致します。
36:tanity :

2014/08/06 (Wed) 20:37:21

初めまして、最近始めたものです。

質問なのですが、iscript(javascript)から、ラベルにjumpさせる事は可能でしょうか?
というのも、jqueryでスワイプ動作を判定して、特定のラベルに処理を飛ばしたいのですが・・・

宜しくお願い致します。
37:AM :

2014/08/16 (Sat) 09:09:43

不具合報告です。

原因は不明ですが、プロジェクトがずっと処理中で開けなくなる現象が発生します。

プロジェクト一覧、にてファイルを選択するとずっと処理中で
とまってしまう現象です。

原因をつきとめる為に、新規プロジェクトを作成し、ファイルを一つずつ入れ替えていったら
シナリオフォルダを入れ替えたときに発生する事がわかりました。

どうしてプロジェクトが開けなくなってしまうのか、何かの拍子でファイルが壊れたのか不明です。

今後の改善のお役に立てればとご報告いたします。
38: :

2014/08/18 (Mon) 10:46:54

不具合報告です。

ティラノビルダーでテスト用のゲームを作っていて気が付いたのですが。
選択肢表示中や文章の終りなどで停止命令が入っているとセーブ、ロードなどの右下のメニューボタンが押せないことがありました。

ティラノビルダーのバージョンは1.6、PC環境はWIN8の64ビット環境です。
ご確認お願いします。
39:AM :

2014/08/19 (Tue) 08:12:30

不具合報告です。

ティラノビルダー内で作成した命令がスプリクトに正しく反映されない場合があります。
例えば、ティラノビルダー内で効果音を鳴らす命令をしてあるとして、それを削除したとします。
セーブした上でスプリクトを開き確認すると反映されていないケースがありました。

また、以前にもご報告させて頂いたのですが、ティラノビルダー内で命令した項目が
一列ずつずれてしまっていたり、移動していたりする事が多々あります。

これは色んなケースがある様なので簡単に起こったケースをまとめると
●保存した時にあるスプリクトだけが2つずつ複製されてしまっていたりする。
 結果、同じセリフを二回言ったり、同じ効果音が2回なったりする。
●【これはわりと多く発生したケースですが】下の方に作成した命令が上の方へ丸ごと
 移動してしまっている。
●既に出来ているスプリクトに後で音だけ追加しようと効果音を追加したら追加した
 その効果音とその上下のスプリクトがくっついてくるかのように3つ程上に移動して
 しまっていた。

伝わり辛い説明で恐縮ですが、こういった感じになります。
環境はWIN7 64ビット になります。

ティラノビルダーはスプリクトが全然分からない私の様な者にとってゲーム作りを始める
きっかけになった物です。今後のお役に立てればと考え、恐縮ですが積極的に書き込みをさせて頂こうと思います。

40:AM :

2014/08/19 (Tue) 10:17:25

追記です。度々失礼致します。

ビルダーで入れた、ラベル *start の下に入れたティラノスプリクト欄がそっくり
消えてしまう現象が二度同じ場所で発生しました。中身は変数の計算式です。
場所も内容もまったく同じ物が二度消えました。

どこかに移動しているかと探しましたが
見当たらりませんでした。

度々恐縮です。ご確認いただければと思います。
41:tequila :

2014/08/20 (Wed) 23:39:22

こんにちは

BGMを挿入するまではいいのですが、プレビュー画面での再生ができません
シナリオ画面で音楽の再生はできるのですが、ファイル名が表示されていません
42:inaba :

2014/08/21 (Thu) 14:04:04

>>41
同じくBGMが再生されません。
43:烈風 :

2014/08/31 (Sun) 09:12:53

チュートリアル中に支持に従い画像を設定すると「動作が停止しました」と表示されて強制終了してしまうんですがどうしたら良いですか?
44:照蔵 :

2014/09/06 (Sat) 18:16:26

テキストが表示されません。

テキストに何も打ち込まないで、ガイドのやつをやってみたんですが、途中で止まったりして、全く動く気配がありません。
どうすれば、いいんでしょうか?
45:taro :

2014/09/15 (Mon) 23:14:13

26 27 で書かせて頂いたものです。

バージョンが上がってたので再度試してみたのですが
ティラノビルダーではクエイクの縦揺れが反映されません。

直接 scene1.ks 内の横揺れの命令を消すと縦揺れが出来るようになるのですが
斜めに揺らす事は出来ません。

ティラノビルダー上で縦揺れを反映して貰えませんでしょうか?

OS:Windows7 64bit です。
46:だいきち :

2014/09/22 (Mon) 05:26:39

いつもお世話になっております。

不具合かどうか分かりませんが
ビルダーの機能の「ゲームを保存する」がクリックできなくなりました。
他のプロジェクトでは問題ないので、
現在作業中のプロジェクトに問題があるはずなのですが
その直前に行った作業がキャラ登場と変更だけなので...
(そのシーンでゲームが止まったため該当の立ち絵は削除しています。)
その後、プレビュー中にビルダー自体がフリーズしております。
OSはWin7です。

何か対処法がありましたら教えて下さい。


それから、
>>33 テストロン様も仰っている
セーブ時の確認メッセージウィンドウの中味が見切れていてボタンが押しづらい
現象ですが、OSをXPから7へ変更したところ解決しました。
同じ現象でお困りの方の参考になればと思います。

47:だいきち :

2014/09/25 (Thu) 00:21:26

>>46  ビルダーがフリーズしてしまった件ですが、
v016に入っていたデータをv017に移動してみたところ動きました!
v016からv016へ移動した際はフリーズしていたのですが、一先ず大丈夫そうです。
お騒がせいたしました。

v017、アラートメッセージが見易くなっていたのですね!
ありがとうございます!作業中のうっかりも減りそうです。
48: :

2014/10/06 (Mon) 01:48:11

いつもお世話になっております。

不具合かどうか分りませんが。
v017を早速使用させて頂いているのですが、キャラクター登場時の表情の指定が出来ません。
以前のバージョンと同じく、キャラ登場の前にキャラ変更を置いているのですがうまくいきません。
一度ビルダー自体を削除、ダウンロードし直して、やり直しをしてみたのですが、やはり上手くいきませんでした。
OS:Windows7 64bit です。
49:ての字 :

2014/10/12 (Sun) 15:40:31

>>48
私も同じ症状で困っていましたが、透明な画像を用意して
それを表示してから切り替えるようにして対処しています。
50: :

2014/10/12 (Sun) 16:12:40

>>49 ての字様
48の黒です。
対処法のアドバイスありがとうございます!
お陰で解決しました!
本当にありがとうございました!
51:ぺの :

2014/10/12 (Sun) 22:42:10

お世話になっております。今日ティラノビルダーを使い始めた初心者です。

とても初歩的な質問で大変恐縮なのですが、自分で作ったキャラクターを登場させようとすると小さいアイコンが表示されてキャラが表示されません。
チュートリアル通りに「ゆうこpng」をダウンロードし、キャラクター登録をしてからすると「ゆうこ」は問題なく登場します。
サイズやbitが間違っているのかなと思って試したのですがだめでした。画像はちゃんと透明にしています。

ご回答いただけると大変ありがたいです。
52:たりら :

2014/10/21 (Tue) 12:39:54

初めまして。最近ゲーム制作を始めた初心者です。
主人公の名前を変えられるノベルゲームを作ろうと思っているのですが、テキストボックスの中にデフォルト名を表示させるにはどのようにしたらよいでしょうか?
下記のスクリプトだと、テキストボックスは空欄になっております。

[tb_hide_message_window ]
[tb_start_tyrano_code]
[edit name="f.namae" color=black maxchars=5 left=200 top=150 size=30 height=30 width=150]
[locate x=360 y=152 ]
[button graphic="kettei.png" width="45" height="27" target=*commit]
[s]
*commit
[commit]
[cm]


また、会話中で主人公の名前を呼ぶ時に

#
君が[emb exp=f.namae]なのね。よろしく!

と書いているのですが、[ ]の部分が分割されてしまいます。


君が(クリックする)
[emb exp=f.namae]なのね。よろしく!

改善方法をご教授いただけましたら幸いです。
53:イズミ :

2014/10/27 (Mon) 01:24:45

初めまして。ゲーム制作初心者です。環境はWindows 7/64bitです。
不具合かどうかわからないのですが、何度やり直してもできないので一応…!

【効果音再生】に音楽を選んで(ちゃんとmp3です)一度保存し、そのシナリオにいる間は
普通に再生されるのですが別のシナリオに移動したあとに戻ってくるとファイルを選択してい
たのに消えています。
【効果音再生】は残っているのですがファイルが指定されてない状態になってるものと、
一度保存してしまえば何ら問題なく動くものとあってよくわかりません…。
一度消して設定し直しても直りませんでした。(同じ箇所のみ)
↑Ver0.1.6でもVer0.1.7でもです。
私の用意している音楽ファイルが悪いのでしょうか。

他にも一度保存したにもかかわらず、改めて開くとシナリオが移動している、なども多かったように感じます。

初めての掲示板への書き込みなので、分かりづらかったら申し訳ございません。
54:イズミ :

2014/10/27 (Mon) 01:31:39

>>53
申し訳ないです!
前に質問され、解決されていたことでした。
>解決策:ファイル名が長かったためであり、短くすると直る。

確認を怠りすみませんでした。きちんと直りました。
55:すがたく :

2014/10/30 (Thu) 20:58:53

お世話になっております。

不具合が起こるのは、スタート画面で「つづきから」というボタンを押すと、ロード画面に移って(ここまでは問題なし)、
ゲームの続きをプレイする時です。
毎回背景の切り替えがうまくいかず、キャラと台詞は表示されているのに背景だけがタイトル画面のまま、というみっともない感じになります。


バージョン0.1.7での現象です。
同じことが起こっている方、または不具合を解決した方はおりますでしょうか。
(ちなみに私が使っているPCは Windows vista/8.1)

ビルダーの方ではなく、ティラノスクリプトでタグ打ちした方がまだ安定性はありますかね?
56: :

2014/11/05 (Wed) 16:02:09

キャラクター登場時の表情の指定が出来ませんの方へ、私はいい方法見つけた。
まず、あなたのプロジェクトフォルダから tyrano\plugins\kag を開き、kag.tag_ext.js をNotepadでオープンしてコード表示します。
Ctrl+F で +pm.storage;$("."+pm.name).attr("src",storage_url); を探して this.kag.stat.charas[pm.name]["storage"]=pm.storage; を追加にします。
セーブして、これでキャラクター変更が大丈夫です。
57:ましゅまろ :

2014/11/06 (Thu) 21:28:03

こんばんは。質問させて頂きます。
試しにテストプレイでセーブ画面を開き、
ゲームを保存したんですが、つづきからをクリックすると、
「まだ、保存されているデータがありません」
と表示されていて、以前。保存したデータのつづきから
プレイすることができません。
保存ができる方法を教えてください。
58:AM :

2014/11/07 (Fri) 13:55:12

不具合報告

シナリオエディタ内に入っているコンポーネントがコピーされ2個ずつになる現象が
度々起こります。(テキストであれば、同じ文章が二回流れるといった結果になります。)

複製されたのがテキストでしたので、見た目で違和感がありわかりましたが、
音楽や効果音、改行といったその他の物も自動複製される事があります。
59:ましゅまろ :

2014/11/08 (Sat) 08:25:15

あのー・・・
どうしても、保存ができないんです。
どうして保存ができないのか、本当に教えてください;;
困ってるんです。
このままでは、完成できないんです
助けてください;;
60:AM :

2014/11/08 (Sat) 17:42:24

■不具合報告■
キャラクター管理にて新規にキャラクターを登録する事ができますが
3人登録した時点では正常、その後4人目を登録したのですが
その4人目を登場させた時点でフリーズします。

登場させる場面を変えても同じくフリーズします。
ファイル形式もPNGで問題ありません。
何度か削除し、新規に5人目6人目と作り直しましたが
同じくフリーズします。

3人目までは正常に登録、登場出来ておりました。

※別件ですがスキップモードによるフリーズの確立も非常に高いです。
61:AM :

2014/11/08 (Sat) 18:16:49

■不具合報告■
キャラ変更が効かない事があるようです。
例えば、キャラクターA(1枚目から10枚目まで絵柄が登録してある)
を退場させ、再度表情パターンを変えて登場させる場合、2枚目の絵柄を選んだとします。

しかし登場する際には一番最初に登録した1枚目が出現してしまいます。
どの方法を使ってもこれは変わりませんでした。

※不具合のようだったので、これを回避するために一度透明度を0にして登場させ
(実際には登場しているのですが透明度が0なので見えていない)登場させた後で
キャラクターの画像を変更→透明度を元に戻す ・・・この方法であればキャラ変更は効きます。

問題は一度退場したキャラクターが再登場した場合、
どういった条件でも1番初めに登録した画像で出現してしまうという事です。
62:すがたく :

2014/11/09 (Sun) 22:08:14

>ましゅまろさん

私はWindows8.1、ビルダーは最新の0.1.7を使っています。
が、セーブデータが保存されていない、といったことにはなりません。


その現象はティラノビルダーの「プレビュー」ボタンを押してテストをした時のものですか?
それともレンタルサーバー(FC2など)にアップしたらそうなったのですか?
毎回保存できずに困っているのですか?

その時使っていたOS(たとえばWindows8といったように)と、ティラノビルダーのバージョンは何でしょう。

これらが分かれば他の方が返信してくださるかも。

63:ましゅまろ :

2014/11/10 (Mon) 10:45:39

>すがたくさん

プレビューを押して、テストプレイをしました。
毎回テストプレイしてセーブしても
「まだ、保存されているデータがありません」と表示されます。
つづきからプレイすることができません。
名前入力を追加したら、セーブができなくなりました。
FC2にアップしていません。

tyranobuilder_win_v017
というファイルをダウンロードしました。
64:AM :

2014/11/12 (Wed) 07:15:46

■不具合報告■
>61でも記述しましたが追記です。

※win_v017になってからキャラクター登場・変更等の周辺に不具合がある様に思われます。
ゲーム制作する際に重大な事となってしまいますので一度見直して頂けませんでしょうか。

まとめると
●新規にキャラクターを登録する際、そのキャラクターを登場させる事でフリーズしたりする。
(タイミングは分かりかねますが成功する場合とそうでない場合があります)
●「キャラクターを登場」させる以前に「キャラクターの変更」をさせても、変更されない。
(登場した後では繁栄され、変更する事が出来る。)

>48・49でも既に出ている通り、ただキャラクターを変更させるだけでも透明な画像を用意したり、
スクリプトで透明にしてから登場させ、画像を変更させてから透明化を元に戻す、といった作業を
毎回しなければならず、作業効率に負荷がかかります。

65:AM :

2014/11/12 (Wed) 08:36:25

■不具合報告■
ctrlキーを押しての複数選択→コピー→貼り付け 時に正しい順番で貼り付けされない場合があります。


シナリオ1で複数選択→コピー→シナリオ2に移動、貼り付け→貼り付け時に一番したの欄が先頭に来ており順序が狂ってしまっている

※コピー→貼り付けで順番が狂う以外にもセーブ時や不明なタイミングでシナリオエディタ内の順序が
 入れ替わってる場合がございます。(最後の物が先頭に、といった例が何故か多いです)
66:AM :

2014/11/12 (Wed) 08:43:29

>65
この症状は初回のみです。貼り付けられた物を削除して再度、貼り付けを行うと
正しい順序で貼り付けされています。

ただし、シナリオを移動した際、再度貼り付けを行うとまた順序が乱れており
削除して貼り付け、といった方法を取らねばなりません。

記述し忘れましたがwin_v017での確認になります。
67:すがたく :

2014/11/13 (Thu) 23:30:21

どうも。
バージョンアップによりアラートの表示が見やすくなったので、本当に助かりました。
このたび短編を無事発表いたしました。わーい(´∀`*)

>55
での件、サーバーにアップすれば解決するようです。
「ティラノビルダー」内のプレビューからゲームをプレイすると背景の切り替えがおかしくなるみたい。

今回はそれとは別件なのですが、ビルダーのバージョン0.1.6を使っていて
「[iscsript]コンポーネントが機能しない!」
と嘆いていたのを思い出しました。
あれは使い方が悪かったのかしら…改めて試してみます。

※バージョン0.1.7の挙動は片っ端からチェックしたわけではないので、
みなさまにちゃんとしたお返事ができなくてすみません。
68:プリン :

2014/11/27 (Thu) 17:36:56

ティラノビルダー(MacOS版 0.1.7)が起動する前に落ちてしまいます。
OS Mac10.6.8
69:プリン :

2014/11/27 (Thu) 17:38:32

落ちた際のメッセージです

Process: node-webkit [346]
Path: /Users/XXX/Desktop/tyranobuilder_mac_v017/tyranobuilder.app/Contents/MacOS/node-webkit
Identifier: com.intel.nw
Version: 0.01 (alpha)
Code Type: X86 (Native)
Parent Process: launchd [132]

Date/Time: 2014-11-27 17:34:37.695 +0900
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 96927 sec
Crashes Since Last Report: 4
Per-App Interval Since Last Report: 24 sec
Per-App Crashes Since Last Report: 3
Anonymous UUID: 06E055D9-B2F6-43EA-8C14-A18A02578896

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 0 CrBrowserMain Dispatch queue: com.apple.main-thread
70:プリン :

2014/11/27 (Thu) 17:40:06

続きです

Thread 0 Crashed: CrBrowserMain Dispatch queue: com.apple.main-thread
0 node-webkit Framework 0x57bcaca9 uv_fs_event_init + 6450425
1 com.apple.AppKit 0x96d1ae66 -[NSView _setWindow:] + 2131
2 com.apple.AppKit 0x96d23aca -[NSView addSubview:] + 411
3 com.apple.AppKit 0x96eacff6 -[NSView addSubview:positioned:relativeTo:] + 708
4 node-webkit Framework 0x57c28e14 uv_fs_event_init + 6835812
5 node-webkit Framework 0x57c228e8 uv_fs_event_init + 6809912
6 node-webkit Framework 0x57c22a62 uv_fs_event_init + 6810290
7 node-webkit Framework 0x57c10f25 uv_fs_event_init + 6737781
8 node-webkit Framework 0x57c0f0e8 uv_fs_event_init + 6730040
9 node-webkit Framework 0x57c0ed5d uv_fs_event_init + 6729133
10 node-webkit Framework 0x57c1b6ed uv_fs_event_init + 6780733
11 node-webkit Framework 0x57c1b5c0 uv_fs_event_init + 6780432
12 node-webkit Framework 0x57c07b90 uv_fs_event_init + 6700000
13 node-webkit Framework 0x57c08d2f uv_fs_event_init + 6704511
14 node-webkit Framework 0x590368ab v8::internal::NativesCollection<(v8::internal::NativeType)1>::SetRawScriptsSource(v8::internal::Vector<char const>) + 1669819
15 node-webkit Framework 0x5903a6c3 v8::internal::NativesCollection<(v8::internal::NativeType)1>::SetRawScriptsSource(v8::internal::Vector<char const>) + 1685715
16 node-webkit Framework 0x59005dd5 v8::internal::NativesCollection<(v8::internal::NativeType)1>::SetRawScriptsSource(v8::internal::Vector<char const>) + 1470437
17 com.apple.Foundation 0x97f87db3 _nsnote_callback + 176
18 com.apple.CoreFoundation 0x997c5763 __CFXNotificationPost + 947
19 com.apple.CoreFoundation 0x997c516a _CFXNotificationPostNotification + 186
20 com.apple.Foundation 0x97f7cc50 -[NSNotificationCenter postNotificationName:object:userInfo:] + 128
21 com.apple.Foundation 0x97f8a05d -[NSNotificationCenter postNotificationName:object:] + 56
22 com.apple.AppKit 0x96d77216 -[NSApplication _postDidFinishNotification] + 125
23 com.apple.AppKit 0x96d77126 -[NSApplication _sendFinishLaunchingNotification] + 74
24 com.apple.AppKit 0x96ece339 -[NSApplication(NSAppleEventHandling) _handleAEOpen:] + 274
25 com.apple.AppKit 0x96ecdf59 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 101
26 com.apple.Foundation 0x97fbd1f8 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 511
27 com.apple.Foundation 0x97fbcfbc _NSAppleEventManagerGenericHandler + 228
28 com.apple.AE 0x95995f5c aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*) + 166
29 com.apple.AE 0x95995e5b dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 43
30 com.apple.AE 0x95995d65 aeProcessAppleEvent + 197
31 com.apple.HIToolbox 0x9668e197 AEProcessAppleEvent + 50
32 com.apple.AppKit 0x96d477d2 _DPSNextEvent + 1420
33 com.apple.AppKit 0x96d46dd6 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156
34 com.apple.AppKit 0x96d091f3 -[NSApplication run] + 821
35 node-webkit Framework 0x5733199d v8::Locker::StopPreemption() + 8798605
36 node-webkit Framework 0x5733102c v8::Locker::StopPreemption() + 8796188
37 node-webkit Framework 0x5736bbb1 v8::Locker::StopPreemption() + 9036705
38 node-webkit Framework 0x57385e7e v8::Locker::StopPreemption() + 9143918
39 node-webkit Framework 0x579db883 uv_fs_event_init + 4421843
40 node-webkit Framework 0x579db75c uv_fs_event_init + 4421548
41 node-webkit Framework 0x579dc9a4 uv_fs_event_init + 4426228
42 node-webkit Framework 0x59039fe9 v8::internal::NativesCollection<(v8::internal::NativeType)1>::SetRawScriptsSource(v8::internal::Vector<char const>) + 1683961
43 node-webkit Framework 0x5903d543 v8::internal::NativesCollection<(v8::internal::NativeType)1>::SetRawScriptsSource(v8::internal::Vector<char const>) + 1697619
44 node-webkit Framework 0x58981387 _CTFontManagerUnregisterFontForData + 4806567
45 node-webkit Framework 0x589821c1 _CTFontManagerUnregisterFontForData + 4810209
46 node-webkit Framework 0x58981050 _CTFontManagerUnregisterFontForData + 4805744
47 node-webkit Framework 0x56862999 ContentMain + 41
48 com.intel.nw 0x5685ef75 0x5685e000 + 3957
71:M&A :

2014/11/30 (Sun) 22:55:12

bgmが停止されません。
どうしたらいいですか?
72:AM :

2014/12/01 (Mon) 20:38:03

■■不具合報告 効果音の不具合■■
win0.17
シナリオエディタ内に組み込んだ効果音が、
プレビューで鳴っている事を確認できた後に数日して、鳴らなくなる不具合があります。
原因は不明です。

パラメータ内で三角の再生ボタンを押しても音は鳴りません。
オーディオファイル選択で音の再生を確認しても鳴りません。
(前回は鳴っていました。鳴らなくなった音のファイルは複数あります。)

一度鳴る事を確認できる上、鳴らなくなる原因が不明な為、他のバグと違って
対策のしようがございません。

ゲーム製作をする上で深刻ですので直して頂けるとありがたいです。
どうか宜しくお願い致します。
73:AM :

2014/12/01 (Mon) 20:42:48

>72追記
一度ビルダーを閉じて再度起動したら鳴る様に鳴っていましたが
度々こういった現象が起こります。一度改めて頂けると幸いです。宜しく願います。
74:りょうこ :

2015/01/17 (Sat) 11:30:12

すみません、書き込むスレッド間違えたので、こちらのほうに書き直します。
初めまして。
初心者の私でも簡単にゲームが作れて、ティラノビルダーは本当に素晴らしいツールだと思います。

さて、ゲーム書き出しについて質問です。
windows版ティラノビルダーver 0.17を使用してます。当方のOSはWindows 8.1です。
MP3ファイル1つと画像ファイルを6枚使用したデモゲームを作成し、macアプリへの書き出しを行ったのですが、「この形式はMacで行ってください。作業を中止します」と表示されました。
exportフォルダにはwindowsアプリとして書き出したものの10分の1程度の容量のフォルダが出来上がっています。

windowsを使用しているとMac対応アプリ形式のゲームへの書き出しはできないのでしょうか?
お忙しいとは思いますが、回答よろしくお願いいたします。
75:レヴィア :

2016/04/18 (Mon) 12:20:38

■不具合報告■
昨日から使用し始めたのですが、効果音のoggファイルは選択画面と動作テストの両方で問題なく再生されるます。
しかし、BGMは選択画面などでは再生できるものの動作テストでは再生されず、他の動作に問題なくBGMだけが動作してない

特にエラー文も無い為対処のしようがありません。
76:きらぽ :

2016/05/04 (Wed) 13:23:54

「キャラクター登場」でキャラクターを選ぼうとすると「nwjsが予期しない理由で終了しました。」そのまま落ちてしまいます。誰か対処法を教えていただけませんか?
77:gm :

2016/08/05 (Fri) 01:24:21

クエイクの揺れ方向は 左右でなく 上下になるでしょうか?

  • 名前: E-mail(省略可):
  • 画像:

Copyright © 1999- FC2, inc All Rights Reserved.